Welcome to the ICM Forum. If you have an account but have trouble logging in, or have other questions, see THIS THREAD.
NOTE: Board emails should be working again. Information on forum upgrade and style issues.
Podcast: Talking Images (Episode 22 released November 17th * EXCLUSIVE * We Are Mentioned in a Book!!! Interview with Mary Guillermin on Rapture, JG & More)
Polls: TV-series (Results), Directors (Jan 2nd), 1980 (Jan 24th), <50 checks (Jan 31st)
Challenges: 1000<400, Sci-Fi/Fantasy, Central American/Andean
Film of the Week: Samâ taimu mashin burûsu, February nominations (Jan 29th)

iCM Bugs

Post Reply
User avatar
Tim2460
Posts: 3164
Joined: October 1st, 2018, 7:23 pm
Location: Dijon, France
Contact:

#1481

Post by Tim2460 »

Removing the # at the end of URL ...

Checking Movie... the # re apears...

And suddenly it works again... had time to do yesterday checks...

Weird behaviour
User avatar
Knaldskalle
Moderator
Posts: 10100
Joined: May 9th, 2011, 6:00 am
Location: New Mexico, Trumpistan
Contact:

#1482

Post by Knaldskalle »

Still not working for me at all.
ImageImageImageImage

Please don't hurt yourself, talk to someone.
User avatar
xianjiro
Donator
Posts: 8709
Joined: June 17th, 2015, 6:00 am
Location: Kakistani Left Coast
Contact:

#1483

Post by xianjiro »

I just used the beta page for the horrible movie I just suffered through. Worked fine. (Oh, v2 seems to be toast.)

"I AM Agador Spartacus!!"

:ICM: :imdb:
User avatar
Onderhond
Posts: 5746
Joined: December 23rd, 2012, 7:00 am
Contact:

#1484

Post by Onderhond »

Javascript is just broken now on every page, so nothing javascript-based (like the search field clear, checks, add to watchlist, ...) will work.
User avatar
xianjiro
Donator
Posts: 8709
Joined: June 17th, 2015, 6:00 am
Location: Kakistani Left Coast
Contact:

#1485

Post by xianjiro »

okay, who sneezed on their computer?!? 😷😩

"I AM Agador Spartacus!!"

:ICM: :imdb:
User avatar
Ebbywebby
Posts: 3691
Joined: September 10th, 2012, 6:00 am
Location: Orange County, CA
Contact:

#1486

Post by Ebbywebby »

I've never seen ICM working as badly as it's working right now. :( At least, the non-beta version.
User avatar
joachimt
Donator
Posts: 33042
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#1487

Post by joachimt »

Marijn just hit some buttons. Can you guys please check if things are better now? Search bar is working normally for me now.
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
joachimt
Donator
Posts: 33042
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#1488

Post by joachimt »

You have to hit ctrl+F5 first btw.
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
PGonzalez
Posts: 420
Joined: September 8th, 2013, 6:00 am
Contact:

#1489

Post by PGonzalez »

joachimt wrote: May 5th, 2020, 10:01 am Marijn just hit some buttons. Can you guys please check if things are better now? Search bar is working normally for me now.
I just checked and favorited something, so it seems to be working fine :)
User avatar
Tim2460
Posts: 3164
Joined: October 1st, 2018, 7:23 pm
Location: Dijon, France
Contact:

#1490

Post by Tim2460 »

For me it's working... but i only made one check / deselect watch list.
User avatar
albajos
Posts: 6942
Joined: May 24th, 2016, 6:00 am
Location: Norway
Contact:

#1491

Post by albajos »

you really need a test version of this site. You can't let everything just go live and see how it goes.
User avatar
PeacefulAnarchy
Moderator
Posts: 25908
Joined: May 8th, 2011, 6:00 am
Contact:

#1492

Post by PeacefulAnarchy »

albajos wrote: May 5th, 2020, 4:05 pm you really need a test version of this site. You can't let everything just go live and see how it goes.
Some things are load dependent. I don't know what exactly went wrong here, but given that it was stuff timing out it's possibly something that would have worked fine on a test server with only one person doing it but chokes when the process is run by too many people at once.
User avatar
Onderhond
Posts: 5746
Joined: December 23rd, 2012, 7:00 am
Contact:

#1493

Post by Onderhond »

PeacefulAnarchy wrote: May 5th, 2020, 4:53 pm
albajos wrote: May 5th, 2020, 4:05 pm you really need a test version of this site. You can't let everything just go live and see how it goes.
Some things are load dependent. I don't know what exactly went wrong here, but given that it was stuff timing out it's possibly something that would have worked fine on a test server with only one person doing it but chokes when the process is run by too many people at once.
It was jQuery not being loaded, which could be load-dependent, but should never be load dependent.
User avatar
Knaldskalle
Moderator
Posts: 10100
Joined: May 9th, 2011, 6:00 am
Location: New Mexico, Trumpistan
Contact:

#1494

Post by Knaldskalle »

I tried to look in the Firefox debugger when the issue was happening to me. It mentioned a load method being deprecated several times. I'm guessing it changed at some point and iCM still used the old method.
ImageImageImageImage

Please don't hurt yourself, talk to someone.
User avatar
xianjiro
Donator
Posts: 8709
Joined: June 17th, 2015, 6:00 am
Location: Kakistani Left Coast
Contact:

#1495

Post by xianjiro »

yeah, it's hard to know what all the dependencies are - that's only something our resident programmer can judge. I'm also guessing the goal is to spend as little time as possible 'fixing' v2 and put as much as possible into v3.

BTW 408 forum guests?

"I AM Agador Spartacus!!"

:ICM: :imdb:
User avatar
AdamH
Site Admin
Posts: 12883
Joined: May 5th, 2011, 6:00 am
Contact:

#1496

Post by AdamH »

It says 1078 guests for me. Record users online was 1806 on 12th March 2020 so I'm guessing the number was even higher that day.
User avatar
Onderhond
Posts: 5746
Joined: December 23rd, 2012, 7:00 am
Contact:

#1497

Post by Onderhond »

Maybe we should call it v2030 to set people's expectations straight B)
User avatar
PeacefulAnarchy
Moderator
Posts: 25908
Joined: May 8th, 2011, 6:00 am
Contact:

#1498

Post by PeacefulAnarchy »

AdamH wrote: May 6th, 2020, 5:48 pm It says 1078 guests for me. Record users online was 1806 on 12th March 2020 so I'm guessing the number was even higher that day.
There's a group of bots that seems rolls around to scan the site from time to time.
Edit: Banned a bunch of them.
User avatar
insomnius
Posts: 827
Joined: January 10th, 2013, 7:00 am
Location: Stockholm
Contact:

#1499

Post by insomnius »

Trying to import a movie, but it doesn't work. No error message though.
User avatar
joachimt
Donator
Posts: 33042
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#1500

Post by joachimt »

insomnius wrote: May 7th, 2020, 10:16 am Trying to import a movie, but it doesn't work. No error message though.
With "import" you mean adding through the add movie page on the beta? Which movie?
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
Tim2460
Posts: 3164
Joined: October 1st, 2018, 7:23 pm
Location: Dijon, France
Contact:

#1501

Post by Tim2460 »

Had tried to import some theses last 2 days.. No luck yet
User avatar
insomnius
Posts: 827
Joined: January 10th, 2013, 7:00 am
Location: Stockholm
Contact:

#1502

Post by insomnius »

joachimt wrote: May 7th, 2020, 10:34 am
insomnius wrote: May 7th, 2020, 10:16 am Trying to import a movie, but it doesn't work. No error message though.
With "import" you mean adding through the add movie page on the beta? Which movie?
That's right. I always tick the "check after adding" box and it always shows up right away in my ckeck flow. But not today.

This film:
https://www.imdb.com/title/tt8703378/reference
User avatar
insomnius
Posts: 827
Joined: January 10th, 2013, 7:00 am
Location: Stockholm
Contact:

#1503

Post by insomnius »

insomnius wrote: May 7th, 2020, 11:11 am
joachimt wrote: May 7th, 2020, 10:34 am
insomnius wrote: May 7th, 2020, 10:16 am Trying to import a movie, but it doesn't work. No error message though.
With "import" you mean adding through the add movie page on the beta? Which movie?
That's right. I always tick the "check after adding" box and it always shows up right away in my ckeck flow. But not today.

This film:
https://www.imdb.com/title/tt8703378/reference
Just tried again, and it worked now. :shrug:
User avatar
joachimt
Donator
Posts: 33042
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#1504

Post by joachimt »

insomnius wrote: May 7th, 2020, 2:54 pm
insomnius wrote: May 7th, 2020, 11:11 am
joachimt wrote: May 7th, 2020, 10:34 am
With "import" you mean adding through the add movie page on the beta? Which movie?
That's right. I always tick the "check after adding" box and it always shows up right away in my ckeck flow. But not today.

This film:
https://www.imdb.com/title/tt8703378/reference
Just tried again, and it worked now. :shrug:
Okay, weird. Glad it got solved at least.
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
Ebbywebby
Posts: 3691
Joined: September 10th, 2012, 6:00 am
Location: Orange County, CA
Contact:

#1505

Post by Ebbywebby »

I have imported LOTS of movies from IMDb to ICM. I can honestly say that I've never had a glitch with this process.
User avatar
AdamH
Site Admin
Posts: 12883
Joined: May 5th, 2011, 6:00 am
Contact:

#1506

Post by AdamH »

This has been a problem for me for a long time but I can't delete personal lists.
User avatar
joachimt
Donator
Posts: 33042
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#1507

Post by joachimt »

AdamH wrote: May 9th, 2020, 6:41 pm This has been a problem for me for a long time but I can't delete personal lists.
My experience is it keeps thinking thinking thinking. I just leave the tab open. It removes the list at one point, but you never get confirmation.
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
PeacefulAnarchy
Moderator
Posts: 25908
Joined: May 8th, 2011, 6:00 am
Contact:

#1508

Post by PeacefulAnarchy »

Yeah, deleting works but takes a loooong time. I tend to just repurpose my handful of test lists instead of deleting them.
User avatar
AdamH
Site Admin
Posts: 12883
Joined: May 5th, 2011, 6:00 am
Contact:

#1509

Post by AdamH »

Yeah, that's what I normally do but it didn't work earlier. I think it might be because I tried to delete 3 or 4 lists at the same time. I'll try again one by one but I have so many pointless personal lists that it takes forever to delete them so I always give up.
User avatar
joachimt
Donator
Posts: 33042
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#1510

Post by joachimt »

Marijn just deleted about 13000 spam accounts. He's working on improving the registration process.
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
Ebbywebby
Posts: 3691
Joined: September 10th, 2012, 6:00 am
Location: Orange County, CA
Contact:

#1511

Post by Ebbywebby »

joachimt wrote: May 11th, 2020, 9:55 am Marijn just deleted about 13000 spam accounts. He's working on improving the registration process.
(l)
User avatar
pitchorneirda
Posts: 305
Joined: February 11th, 2019, 12:07 pm
Location: France
Contact:

#1512

Post by pitchorneirda »

pitchorneirda wrote: May 4th, 2020, 11:07 pm Impossible for me to do any action (check, uncheck, add to a watchlist, remove from a watchlist, etc.) right now, I've been trying for more than 10 minutes, refreshing dozens of time, clearing the cache, I've tried with three different browsers etc.

Edit: it works with the beta though
Since those huge bugs last week have been fixed, everything's working like a charm! The website never worked so well since forever
"Art is like a fire, it is born from the very thing it burns" - Jean-Luc Godard
User avatar
Onderhond
Posts: 5746
Joined: December 23rd, 2012, 7:00 am
Contact:

#1513

Post by Onderhond »

The actual checking of films still fails from time to time.
User avatar
blueboybob
Donator
Posts: 2518
Joined: March 11th, 2013, 6:00 am
Location: DC
Contact:

#1514

Post by blueboybob »

Onderhond wrote: May 11th, 2020, 5:54 pm The actual checking of films still fails from time to time.
I get this all time. I have to switch to comments tab (or another tab). Or hard refresh the page
User avatar
Tim2460
Posts: 3164
Joined: October 1st, 2018, 7:23 pm
Location: Dijon, France
Contact:

#1515

Post by Tim2460 »

I think the import queue is stuck ... or i don't get the site warnings anymore ... For the last 3 of 4 films i have imported

Edit : Ok just checked : it's the warnings that don't work anymore :

https://www.icheckmovies.com/movies/clo ... nd/checks/ was indeed created and checked as i checked the box "check after import"
User avatar
shugs
Donator
Posts: 692
Joined: November 15th, 2014, 7:00 am
Location: Bucharest, Romania
Contact:

#1516

Post by shugs »

Does removing personal lists work? I click on remove and the request just stays in pending.
User avatar
joachimt
Donator
Posts: 33042
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#1517

Post by joachimt »

shugs wrote: May 23rd, 2020, 11:22 am Does removing personal lists work? I click on remove and the request just stays in pending.
It never stops ending, but if you let it run for a while, it gets removed anyhow. It just never gives confirmation.
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
Tim2460
Posts: 3164
Joined: October 1st, 2018, 7:23 pm
Location: Dijon, France
Contact:

#1518

Post by Tim2460 »

I usualy shrink the list back to just one movie before removing the list...
User avatar
PeacefulAnarchy
Moderator
Posts: 25908
Joined: May 8th, 2011, 6:00 am
Contact:

#1519

Post by PeacefulAnarchy »

Tim2460 wrote: May 23rd, 2020, 5:51 pm I usualy shrink the list back to just one movie before removing the list...
Does that help? I remember doing that a couple of times but I don't think I noticed a difference. I just reuse lists.
User avatar
maxwelldeux
Donator
Posts: 8758
Joined: June 7th, 2016, 6:00 am
Location: Seattle-ish, WA, USA
Contact:

#1520

Post by maxwelldeux »

PeacefulAnarchy wrote: May 23rd, 2020, 5:53 pm
Tim2460 wrote: May 23rd, 2020, 5:51 pm I usualy shrink the list back to just one movie before removing the list...
Does that help? I remember doing that a couple of times but I don't think I noticed a difference. I just reuse lists.
That's a good way to do it... thanks for the reminder!
Post Reply