Welcome to the ICM Forum. If you have an account but have trouble logging in, or have other questions, see THIS THREAD.
NOTE: Board emails should be working again. Information on forum upgrade and style issues.
Podcast: Talking Images (Episode 22 released November 17th * EXCLUSIVE * We Are Mentioned in a Book!!! Interview with Mary Guillermin on Rapture, JG & More)
Polls: 1970s (Results), 1950 (Jun 24th), Japan (Jun 30th), Essential Cinema (Jun 30th)
Challenges: Italy, Queer Cinema, Film From Each Year
Film of the Week: Roar, July nominations (Jun 25th)

Forum Maintenance.

Post Reply
User avatar
Torgo
Posts: 3256
Joined: June 30th, 2011, 6:00 am
Location: Germany
Contact:

#41

Post by Torgo »

xianjiro wrote: December 12th, 2020, 10:12 am okay, something that's kind of annoying: previously I had a column (second) display which sub-forum the thread is in. While I see this information under the thread title, it's a bit harder to find. I'd generally look at the second column, if it says "challenges" I just scan down until it doesn't. Then I'd look to the left to see if it's a topic I follow.

Without a shortcut, reading every thread title (even in Active Topics) is a bit less cool. And since the subforum's not always in the same place (though it seems to always be last) it's harder to find.

Maybe this is a template issue that will be fixed when that problem gets resolved.
Ugh, just realized this. Yeah, I for one try to ignore everything in Challenges and Off-Topic, so this would be a huge loss in QoL if it stayed permanent. (Seems it won't)
User avatar
GruesomeTwosome
Donator
Posts: 3536
Joined: February 3rd, 2017, 7:00 am
Location: Industrial Wasteland, USA
Contact:

#42

Post by GruesomeTwosome »

Hmm, after the update now for YouTube videos that are posted, I only see the link and not the embedded YT video player with the title of the video and everything. Which was nice since you could actually see what the video was and not click blind on a YT link. I am on my phone now and not a computer, but not sure if that should make any difference because that was never a problem before when using the forum on my phone.
I’m to remember every man I've seen fall into a plate of spaghetti???

My IMDB profile
ICM
Letterboxd
User avatar
joachimt
Donator
Posts: 34072
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#43

Post by joachimt »

GruesomeTwosome wrote: December 12th, 2020, 5:48 pm Hmm, after the update now for YouTube videos that are posted, I only see the link and not the embedded YT video player with the title of the video and everything. Which was nice since you could actually see what the video was and not click blind on a YT link. I am on my phone now and not a computer, but not sure if that should make any difference because that was never a problem before when using the forum on my phone.
PA knows. It's on his list.
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#44

Post by PeacefulAnarchy »

yes, the no video parsing is the one actual functionality loss It's fixable but I don't know how yet. It may take a couple of days, but it will be back.
Torgo wrote: December 12th, 2020, 1:57 pm What a shock, never saw the orange design before. Returning to flat silver in a second. :sweat:
Silver was the least changed so if you were one of the two dozen people using that the yeah you'll feel much more at home.
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#45

Post by PeacefulAnarchy »

For style page updates this will be done in two parts. Part one is underlying template changes, these will require me to close the forum very briefly for no more than a minute or two. Should hopefully happen some time tonight. The second will be the individual colour tweaks and other smaller things, these will be done style by style and shouldn't require taking down the forum.

I'll update when I have a timeline. All style changes are easily reversible, so even if something goes wrong the forum should not be down for more than a minute or two.
User avatar
GruesomeTwosome
Donator
Posts: 3536
Joined: February 3rd, 2017, 7:00 am
Location: Industrial Wasteland, USA
Contact:

#46

Post by GruesomeTwosome »

joachimt wrote: December 12th, 2020, 6:28 pm
GruesomeTwosome wrote: December 12th, 2020, 5:48 pm Hmm, after the update now for YouTube videos that are posted, I only see the link and not the embedded YT video player with the title of the video and everything. Which was nice since you could actually see what the video was and not click blind on a YT link. I am on my phone now and not a computer, but not sure if that should make any difference because that was never a problem before when using the forum on my phone.
PA knows. It's on his list.
Cool, I didn’t catch that. :thumbsup:
I’m to remember every man I've seen fall into a plate of spaghetti???

My IMDB profile
ICM
Letterboxd
User avatar
joachimt
Donator
Posts: 34072
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#47

Post by joachimt »

Could it be that the "someone posted in the meantime" warning isn't working anymore?
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#48

Post by PeacefulAnarchy »

joachimt wrote: December 12th, 2020, 7:10 pm Could it be that the "someone posted in the meantime" warning isn't working anymore?
It should be working, the setting is enabled.
It just worked for me. It's a per subforum setting so maybe there one subforum where it isn't? Let me know where you think it's not working.
User avatar
joachimt
Donator
Posts: 34072
Joined: February 16th, 2012, 7:00 am
Location: Netherlands
Contact:

#49

Post by joachimt »

I think I just posted together with tourdesb in the "Early cinema...." topic. I noticed posts above mine that weren't there before I posted....... I think.
ICM-profile
Fergenaprido: "I find your OCD to be adorable, J"
User avatar
Fergenaprido
Donator
Posts: 5638
Joined: June 3rd, 2014, 6:00 am
Location: Canada
Contact:

#50

Post by Fergenaprido »

Thanks for all of your work on this PA. Much appreciated. :)

:worship:
User avatar
xianjiro
Donator
Posts: 9583
Joined: June 17th, 2015, 6:00 am
Location: Kakistani Left Coast
Contact:

#52

Post by xianjiro »

joachimt wrote: December 12th, 2020, 7:32 pm I think I just posted together with tourdesb in the "Early cinema...." topic. I noticed posts above mine that weren't there before I posted....... I think.
I had this happen in the past (as in before update) - no idea why, but I also can confirm I saw the post review before signing off last night in this very thread.
User avatar
blueboybob
Donator
Posts: 2522
Joined: March 11th, 2013, 6:00 am
Location: DC
Contact:

#53

Post by blueboybob »

It used to be clicking on a topic brought you to the last unread post. Now it brings you to the begining of the thread
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#54

Post by PeacefulAnarchy »

blueboybob wrote: December 12th, 2020, 10:01 pm It used to be clicking on a topic brought you to the last unread post. Now it brings you to the begining of the thread
PeacefulAnarchy wrote: December 12th, 2020, 11:08 am
joachimt wrote: December 12th, 2020, 10:54 am
PeacefulAnarchy wrote: December 12th, 2020, 10:22 am Yes, those are all default behaviours I had modified, now I get to do it again.
It's good that you mention it though, because I didn't remember until you did (though it should all be written down in my notes).
Can you make this top priority?
I an deal with different colors or things in a different place, but finding out where my oldest unread post is, is a pain in the ass.
BTW, technically this is also "things in a different place" If a thread has unread posts click the little coloured icon on the left of the title, if it's all read you can click on the right near the username.
Image
That should be in the first set of fixes tonight. We'll see
User avatar
kongs_speech
Posts: 1663
Joined: April 4th, 2020, 10:32 pm
Location: FL
Contact:

#55

Post by kongs_speech »

Holy shit. I've been so busy taking care of my mom that this is the first time I've had a second to look at the forum. Looking good!
🏳️‍⚧️
Quartoxuma wrote: A deeply human, life-affirming disgusting check whore.
Image
User avatar
fear of 13
Posts: 72
Joined: October 5th, 2017, 6:00 am
Contact:

#56

Post by fear of 13 »

Thanks for the info. Thought this place looked different.
User avatar
RogerTheMovieManiac88
Posts: 2033
Joined: February 4th, 2017, 7:00 am
Location: Westmeath, Ireland
Contact:

#57

Post by RogerTheMovieManiac88 »

As someone who suffers somewhat with blurred vision and short sightedness due to keratoconus, may I just offer a few thoughts on the new board layout.

I find the new layout and colour backgrounds to be quite a bit softer and less distinct, which has meant that I find it rather harder to focus on words. Also spoilers don't really catch my eye, as they appear as a whitish block against a softer background.

I liked the clarity of text against a pristine background (I forget which style I had gone with). I think the third of the display style options (Prosilver Special Edition) might be the setting I choose to go with out of the three available, but it still seems very washed-out and foggy.

Is there any advice anyone could offer to increase the contrast between text and background? As it is, things don't really catch my eye and I have been finding it hard to focus on posts.

Thanks so much for all you do in keeping the site running, PA!
That's all, folks!
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#58

Post by PeacefulAnarchy »

The new colour layout is temporary, fix is coming. I have to change each little piece of colour individually and while I have a key from the previous template it still takes some time.
User avatar
RogerTheMovieManiac88
Posts: 2033
Joined: February 4th, 2017, 7:00 am
Location: Westmeath, Ireland
Contact:

#59

Post by RogerTheMovieManiac88 »

PeacefulAnarchy wrote: December 14th, 2020, 7:47 am The new colour layout is temporary, fix is coming. I have to change each little piece of colour individually and while I have a key from the previous template it still takes some time.
Oh, that is nice to hear. Thanks for the reassurance, PA!
That's all, folks!
User avatar
3eyes
Donator
Posts: 7266
Joined: May 17th, 2011, 6:00 am
Location: Philadelphia
Contact:

#60

Post by 3eyes »

I wish I could see a link to Active Topics instead of having to look at a menu.
:run: STILL the Gaffer!
User avatar
xianjiro
Donator
Posts: 9583
Joined: June 17th, 2015, 6:00 am
Location: Kakistani Left Coast
Contact:

#61

Post by xianjiro »

try this for an active topics link: search.php?search_id=active_topics
User avatar
hurluberlu
Donator
Posts: 2585
Joined: January 4th, 2017, 7:00 am
Contact:

#62

Post by hurluberlu »

PeacefulAnarchy wrote: December 14th, 2020, 7:47 am The new colour layout is temporary, fix is coming. I have to change each little piece of colour individually and while I have a key from the previous template it still takes some time.
Hey, how is this going PA ?
#JeSuisCharlie Liberté, Liberté chérie !

Image
ImageImageImageImage
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#63

Post by PeacefulAnarchy »

It's been a very busy week, I'll be free by tomorrow night and then should get all that stuff done.
User avatar
hurluberlu
Donator
Posts: 2585
Joined: January 4th, 2017, 7:00 am
Contact:

#64

Post by hurluberlu »

Great ! :thumbsup:
#JeSuisCharlie Liberté, Liberté chérie !

Image
ImageImageImageImage
User avatar
sol
Donator
Posts: 11685
Joined: February 3rd, 2017, 7:00 am
Location: Perth, WA, Australia
Contact:

#65

Post by sol »

Any updates? :unsure: I tried to add 'Active Topics' into my signature in lieu of an easy link on the forum but it said that I had too many links in my signature. :pinch:
Former IMDb message boards user // iCM | IMDb | Letterboxd | My top 750 films // Long live the new flesh!
Image Image Image
User avatar
kongs_speech
Posts: 1663
Joined: April 4th, 2020, 10:32 pm
Location: FL
Contact:

#66

Post by kongs_speech »

I miss our ICM logo. "phpBB" is really off-putting to me for some reason.
🏳️‍⚧️
Quartoxuma wrote: A deeply human, life-affirming disgusting check whore.
Image
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#67

Post by PeacefulAnarchy »

I feel the same, hopefully by tomorrow some progress.
User avatar
St. Gloede
Moderator
Posts: 12513
Joined: May 6th, 2011, 6:00 am
Contact:

#68

Post by St. Gloede »

I have the active topics link as a bookmark, placed in my top menu line. Just as fast (if not faster) than the onsite option.
User avatar
sol
Donator
Posts: 11685
Joined: February 3rd, 2017, 7:00 am
Location: Perth, WA, Australia
Contact:

#69

Post by sol »

I am aware that there are workarounds, but PA did mention before that it would be pretty easy/simple to get an Active Topics link again.
Former IMDb message boards user // iCM | IMDb | Letterboxd | My top 750 films // Long live the new flesh!
Image Image Image
User avatar
sol
Donator
Posts: 11685
Joined: February 3rd, 2017, 7:00 am
Location: Perth, WA, Australia
Contact:

#70

Post by sol »

Oh, and if we could get rid of the "open in new window" symbols next to every link. It's annoying. :ermm:
Former IMDb message boards user // iCM | IMDb | Letterboxd | My top 750 films // Long live the new flesh!
Image Image Image
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#71

Post by PeacefulAnarchy »

sol wrote: December 27th, 2020, 10:55 am Oh, and if we could get rid of the "open in new window" symbols next to every link. It's annoying. :ermm:
Can you take a picture of this I don't know what you mean.
User avatar
maxwelldeux
Donator
Posts: 9065
Joined: June 7th, 2016, 6:00 am
Location: Seattle-ish, WA, USA
Contact:

#72

Post by maxwelldeux »

Image
User avatar
sortile9io
Posts: 3306
Joined: January 23rd, 2013, 7:00 am
Contact:

#73

Post by sortile9io »

And make links open by default in a new tab instead of a new window.
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#74

Post by PeacefulAnarchy »

maxwelldeux wrote: December 27th, 2020, 6:44 pm Image
That's a forum setting here: ucp.php?i=179

Or do you mean you want it to open in a new window, but not have the symbol. That should be possible but I don't know where that is in the code.
sortile9io wrote: December 27th, 2020, 7:41 pm And make links open by default in a new tab instead of a new window.
I don't think that's possible. You should be able to set that in your browser. For me everything opens in a new tab.
User avatar
AdamH
Site Admin
Posts: 12965
Joined: May 5th, 2011, 6:00 am
Contact:

#75

Post by AdamH »

sortile9io wrote: December 27th, 2020, 7:41 pm And make links open by default in a new tab instead of a new window.
They open in a new tab for me by default and I haven't changed any settings since the forum changed.
User avatar
Torgo
Posts: 3256
Joined: June 30th, 2011, 6:00 am
Location: Germany
Contact:

#76

Post by Torgo »

AdamH wrote: December 27th, 2020, 7:55 pm
sortile9io wrote: December 27th, 2020, 7:41 pm And make links open by default in a new tab instead of a new window.
They open in a new tab for me by default and I haven't changed any settings since the forum changed.
Same here.

Wow, would a new window be annoying. :blink:
User avatar
Fergenaprido
Donator
Posts: 5638
Joined: June 3rd, 2014, 6:00 am
Location: Canada
Contact:

#77

Post by Fergenaprido »

PeacefulAnarchy wrote: December 27th, 2020, 7:43 pm
maxwelldeux wrote: December 27th, 2020, 6:44 pm Image
That's a forum setting here: ucp.php?i=179

Or do you mean you want it to open in a new window, but not have the symbol. That should be possible but I don't know where that is in the code.
I think he means to not have the symbol. Same for me, it was never there (but new links always opened in new tabs, and still do after the update), but that symbol is new since the update. I've gotten used to it now, but I can see how it could be annoying.

What's more annoying to me is how URLs get truncated after a certain number of characters. I don't know if that's something that can be fixed in the code or not.
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#78

Post by PeacefulAnarchy »

I'll try to see where that symbol is coming from, I'm not sure.
Fergenaprido wrote: December 27th, 2020, 9:09 pm What's more annoying to me is how URLs get truncated after a certain number of characters. I don't know if that's something that can be fixed in the code or not.
Can you link me a post where this happens? I'm not sure what you mean.
User avatar
PeacefulAnarchy
Moderator
Posts: 25943
Joined: May 8th, 2011, 6:00 am
Contact:

#79

Post by PeacefulAnarchy »

OK, first minor change worked ok. Working on the logo and main thread links, then I'll work on the others stuff.

Edit: OK step 2 worked as well. Active topics is there in prosilver SE, will get it in the others soon.
User avatar
Fergenaprido
Donator
Posts: 5638
Joined: June 3rd, 2014, 6:00 am
Location: Canada
Contact:

#80

Post by Fergenaprido »

PeacefulAnarchy wrote: December 27th, 2020, 9:24 pm I'll try to see where that symbol is coming from, I'm not sure.
Fergenaprido wrote: December 27th, 2020, 9:09 pm What's more annoying to me is how URLs get truncated after a certain number of characters. I don't know if that's something that can be fixed in the code or not.
Can you link me a post where this happens? I'm not sure what you mean.
Here's an example: https://www.icheckmovies.com/movies/?ta ... %2Bnanovic

On my screen, the section "gs=director%3Avojislav" is replaced by an "...".
Post Reply